Here are some possible reasons why your project might not compile with the MixCast SDK:

  • Your project’s Player Settings include one of the following unsupported values:
    • Scripting Backend is set to IL2CPP (only Mono supported currently)
    • Api Compatibility Level is set to .Net 2.0 Subset
  • You’ve deleted the SteamVR plugin or Oculus Utilities package since importing the MixCast SDK — Navigate to your project’s Player Settings and in the Scripting Define Symbols list, remove MIXCAST_STEAMVR or MIXCAST_OCULUS respectively.
  • You updated the MixCast SDK without deleting the old SDK folder first — This can cause conflicts if files have internally been moved or renamed. Retry the update by following the instructions found here.

Was this helpful?