First, ensure that you have either OpenVR or Oculus enabled in your project’s XR Settings and active at runtime.

Next, ensure that your headset has a valid tracking position.

If your project uses SteamVR Seated mode and has a custom build process (not just selecting Build/Build and Run), you may be overwriting the Scripting Define MixCast uses to activate SteamVR-specific logic. You can resolve this issue in one of a few ways:

  • Call ScriptDefineManager.EnforceAppropriateScriptDefines() after assigning your custom Scripting Define list in your C# build script.
  • Include MIXCAST_STEAMVR yourself when appropriate and under your project’s MixCast Settings disable the Apply Sdk Flags Automatically and Enable SteamVR Support settings.

 

Was this helpful?