First, note that MixCast is designed to have the Status Window running in parallel with your experience, since this is how it decides to activate the functionality in your application at runtime.

If you do have MixCast running, then these steps can help diagnose where the problem may lie with either of the main running processes:

MixCast Client

  • Ensure that you have completed MixCast user setup, that the MixCast Client running (Start Menu/Run MixCast), and that both your experience and the MixCast Client are running at the same Windows permission level (ie: if you ran MixCast as admin/not, run your experience using the same).
  • Ensure MixCast hasn’t been just been set to hide your desktop or in-VR display output

MixCast SDK

  • Ensure that in your project’s Player Settings, Scripting Backend isn’t set to IL2CPP; this configuration is not yet supported.
  • If running your experience in the Unity Editor, ensure that in your project’s MixCast settings you have enabled the Enable MixCast in Editor setting.
  • If running your experience as a Standalone app, ensure that in your project’s MixCast Settings you haven’t enabled the Require Command Line Arg setting, or are launching the experience with the command line argument -mixcast

Was this helpful?